General forum issues - Page 64 - SkyscraperCity
 

forums map | DMCA | news magazine | posting guidelines

Go Back   SkyscraperCity > Fun Forums > About the forums

About the forums » Testing | Archive


Reply
 
Thread Tools
Old March 11th, 2019, 07:15 PM   #1261
UNIT-er
Super Moderator
 
UNIT-er's Avatar
 
Join Date: Jun 2014
Posts: 4,530
Likes (Received): 6710


Regarding that thread I just deleted/undeleted a post to force the forum to recalculate the thread.
Normally this works in such cases.

Please try to view that thread logged in/logged out again and give us a feedback.

Last edited by UNIT-er; March 11th, 2019 at 07:54 PM. Reason: Spelling
UNIT-er no está en línea   Reply With Quote
Sponsored Links
Advertisement
 
Old March 11th, 2019, 09:45 PM   #1262
MichalJ
Registered User
 
Join Date: Nov 2007
Posts: 16,255
Likes (Received): 8710

No change.

"Recaltulating a thread" did work for another bug (where latest posts were invisible even when logged in).
MichalJ no está en línea   Reply With Quote
Old March 12th, 2019, 05:03 PM   #1263
Guest84980932
Registered User
 
Join Date: Mar 2019
Posts: 1
Likes (Received): 3

Hi, everybody!
I am here for a while...

Many years I hadn't got registration here and I followed comments and threads in the forum as a visitor (without logging). But problems started occurring. And this started pissing me off.

So, three hours ago I typed in Google "skyscrapercity visible problems". That's how I found this topic. I read that many of you have this problem (when you are not logged in). That's why I started searching way to solve my (your) problems. And I found two compromise variants.

And before some minutes ago I made temporary registration here (without any intentions to use it later) to be able to share you 2 different ways visitors (as me) to see what is hidden.

First variant:
for example - this thread - when you are not logged in but read comments and browse through pages (clicking on pages numbers on top or bottom of the thread or using "<" or ">" ) you probably see "https://www.skyscrapercity.com/showthread.php?t=1812483&page=64" (for current thread and page). When you hover the button for page 63 - "https://www.skyscrapercity.com/showthread.php?t=1812483&page=63" and etc...

To be able to see comments in these pages just add "&amp=1" to the web address so it start looking like this: "https://www.skyscrapercity.com/showthread.php?t=1812483&page=63&amp=1"
Doing this - you will be capable to see hidden comments (when you are not logged in) but you will see it like you are browsing the forum on your mobile.

The second way is the following:
1. Directly in the address bar (when you are not logged in and there isn't any cache and cookies in your browser - like you are using private browsing in Firefox) - type "skyscrapercity.com"
2. On loaded page press "ctrl+U".
You probably see this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en">
<head>
<link rel='amphtml' href='https://www.skyscrapercity.com/?amp=1' />
<!-- no cache headers -->
<meta http-equiv="Pragma" content="no-cache" />
<meta http-equiv="Expires" content="-1" />
<meta http-equiv="Cache-Control" content="no-cache" />
<!-- end no cache headers -->
<meta name="google-site-verification" content="strange combination of letters and numbers (hash tag)" />
3. Copy the bold combination.
4. For example: at this moment you are on page 64. You want to see page 63. You go on it but when you are already on page 63 - the forum shows page 63 as final and no traces from page 64. Bad.
To see it again (page 64) - in the address bar of the browser type "https://www.skyscrapercity.com/showthread.php?t=1812483&page=64" and add "&"+"bold combination above" (google-site-verification hash tag).
If you do it right the address should be look like this "https://www.skyscrapercity.com/showthread.php?t=1812483&page=64&strange combination of letters and numbers" - Loading this will show you all comments on page 64. If you have troubles to see some of the content on page 63 - change in address bar 64 to 63 and load the page.
Manually add "&strange combination" to all addresses of the pages and you will haven't got any visibility problems with pages' content.

I think this shits occur because when people use private browsing or they have the habit of manually deleting cookies often and visit forum as visitors, the information about this hash tag is not inherited correctly when you browse through the pages of the forum and... this reflects to broken visibility of the content of the pages.

Now it is time to leave this temporary profile and back as a visitor.

Bye!
__________________

Jan, kanye, julianorc liked this post
Guest84980932 no está en línea   Reply With Quote
Old March 13th, 2019, 05:08 PM   #1264
madboy
Registered User
 
Join Date: Oct 2013
Posts: 539
Likes (Received): 175

Is there any update regarding not being able to see posts while logged out?
madboy no está en línea   Reply With Quote
Old March 14th, 2019, 02:52 AM   #1265
AnOldBlackMarble
read lightship chronicles
 
AnOldBlackMarble's Avatar
 
Join Date: Aug 2010
Location: Los Angeles
Posts: 1,798
Likes (Received): 6676

Why is there a "Free Online Job Portal" thread in the megatalls that is only visible on the front page preview. Seems like a trojan to me, or worse. It's been there for hours.

__________________
Read my science fiction adventure Lightship Chronicles.com
AnOldBlackMarble no está en línea   Reply With Quote
Old March 14th, 2019, 11:14 AM   #1266
VS-Maria
Administrator
 
Join Date: Feb 2019
Posts: 17
Likes (Received): 0

Nope, no updates unfortunately.

Maria
VS-Maria no está en línea   Reply With Quote
Old March 14th, 2019, 11:36 AM   #1267
Jan
High there, what's up!
 
Jan's Avatar
 
Join Date: Jul 2002
Location: SkyscraperCity
Posts: 29,192
Likes (Received): 20079

Quote:
Originally Posted by AnOldBlackMarble View Post
Why is there a "Free Online Job Portal" thread in the megatalls that is only visible on the front page preview. Seems like a trojan to me, or worse. It's been there for hours.
That was the title of the thread which has the latest post in that forum, which in this case was a new spam thread. Even if you delete the post or thread, that 'latest thread title' indeed still shows, even though it points to a blank page as it was already deleted. The easy fix is to make a posting in any thread in that section.
__________________

AnOldBlackMarble liked this post
Jan no está en línea   Reply With Quote
Old March 14th, 2019, 01:08 PM   #1268
skejl
Registered User
 
skejl's Avatar
 
Join Date: Jan 2010
Location: Mielec i Kraków
Posts: 4,414
Likes (Received): 8026

Quote:
Originally Posted by MichalJ View Post
Try this one for size:
https://www.skyscrapercity.com/showt...16746&page=490
There are 490 pages (last post 9 Mar 23:12 CET) for logged-in users but only 488 pages (last post 8 Mar 23:28 CET) for anonymous browsers.

I don't see how things like user's timezone might be relevant to the number of posts displayed in a thread.
Screenshots from me:

– Anonymous (I'm based in Poland) — 5 posts and 3 ads, i.e. https://i.imgur.com/PtG26rH.png, https://i.imgur.com/gqY30D3.png
– Logged in — 14 posts, i.e. https://i.imgur.com/K2XKPeT.png, https://i.imgur.com/EYPRIPI.png, https://i.imgur.com/ql4hXYl.png
– Anonymous over VPN with Canada's IP (Vancouver) — 14 posts and plenty of ads, i.e. https://i.imgur.com/PEoxlIK.png, https://i.imgur.com/dcr4AZN.png, https://i.imgur.com/h7gbdKK.png, https://i.imgur.com/xymNSTK.png, https://i.imgur.com/kgBjLiN.png
– Anonymous over VPN with Belgium's IP (Roosdaal) — only 2 posts and some ads, i.e. https://i.imgur.com/ndpns5l.png

Some screenshots were taken in Firefox whereas others in Safari, but actually I've confirmed this odd behaviour in both browsers.
__________________
DHMO — bądź świadomy/a
skejl no está en línea   Reply With Quote
Old March 14th, 2019, 04:53 PM   #1269
Kyll.Ing.
Registered User
 
Kyll.Ing.'s Avatar
 
Join Date: Nov 2012
Location: Trondheim
Posts: 1,635
Likes (Received): 5346

Quote:
Originally Posted by Jan View Post
That was the title of the thread which has the latest post in that forum, which in this case was a new spam thread. Even if you delete the post or thread, that 'latest thread title' indeed still shows, even though it points to a blank page as it was already deleted. The easy fix is to make a posting in any thread in that section.
Is it possible to make the creation of new threads require moderator approval? I think it would reduce the success of spam attacks by quite a lot if it was implemented for the Megatalls and Supertalls forums. Those forums in particular see a lot of spam attacks because they are at the top of the page, and regular users wouldn't be impacted that much since new Supertalls (and even moreso Megatalls) happen so rarely. It would be a negligible inconvenience for legit users, while stopping many spammers dead in their tracks.
__________________
Poe's law: You can't impersonate stupidity without somebody mistaking it for the real thing.
Kyll.Ing. no está en línea   Reply With Quote
Old March 14th, 2019, 09:26 PM   #1270
vsadmin
Administrator
 
vsadmin's Avatar
 
Join Date: Feb 2018
Posts: 744
Likes (Received): 519

Quote:
Originally Posted by Kyll.Ing. View Post
Is it possible to make the creation of new threads require moderator approval? I think it would reduce the success of spam attacks by quite a lot if it was implemented for the Megatalls and Supertalls forums. Those forums in particular see a lot of spam attacks because they are at the top of the page, and regular users wouldn't be impacted that much since new Supertalls (and even moreso Megatalls) happen so rarely. It would be a negligible inconvenience for legit users, while stopping many spammers dead in their tracks.
It may seem like a negligible inconvenience for users of the site but it will never be treated as a that. I have seen this create extra work for the moderator and support team when both needing to make an effort to find and confirm all legitimate posts but also to deal with the large number of users who will email to complain that the volunteer moderator team is not working hard enough to approve posts in near real time.
-Philip
__________________

Jan liked this post
vsadmin no está en línea   Reply With Quote
Old March 14th, 2019, 10:03 PM   #1271
AnOldBlackMarble
read lightship chronicles
 
AnOldBlackMarble's Avatar
 
Join Date: Aug 2010
Location: Los Angeles
Posts: 1,798
Likes (Received): 6676

Quote:
Originally Posted by Jan View Post
That was the title of the thread which has the latest post in that forum, which in this case was a new spam thread. Even if you delete the post or thread, that 'latest thread title' indeed still shows, even though it points to a blank page as it was already deleted. The easy fix is to make a posting in any thread in that section.
Oh, I see, thanks.
__________________
Read my science fiction adventure Lightship Chronicles.com
AnOldBlackMarble no está en línea   Reply With Quote
Old March 15th, 2019, 01:54 PM   #1272
julianorc
Juliano Costa, MSc.
 
Join Date: Aug 2013
Location: Uberaba/MG
Posts: 1,032
Likes (Received): 634

Quote:
Originally Posted by VS-Maria View Post
Hi julianorc,

thank you for letting us know.
I tested it myself and I was able to see the last post 11362 while being logged in and not.
Would you share some more information like what time + time zone it happened, devise, browser you were using...
Can you include images of both views?

Best regards,

Maria

Hello Maria, sorry my delay in answering it.


All members of the group are experiencing the same issue.


Missing several posts when not logged in.

I'm have always been using firefox. But I also have the same issue trying with Chrome.

Brazil is under GMT -3.

Our thread is:
https://www.skyscrapercity.com/showt...33585&page=569
If you're logged in you'll see up to post #11363 but if you're logged in the last current post is #11367

Updating my test description:
I just opened the same thread with Edge and it's showing all the posts, even for anonymous user.

So it seems that the issue happens. only for Firefox and Chrome.
(this is odd)

Last edited by julianorc; March 15th, 2019 at 02:07 PM.
julianorc no está en línea   Reply With Quote
Old March 15th, 2019, 02:03 PM   #1273
VS-Maria
Administrator
 
Join Date: Feb 2019
Posts: 17
Likes (Received): 0

Hi skejl,

Thank you so much for it! Everything is sent to techs.

Best regards,

Maria
VS-Maria no está en línea   Reply With Quote
Old March 15th, 2019, 02:09 PM   #1274
VS-Maria
Administrator
 
Join Date: Feb 2019
Posts: 17
Likes (Received): 0

Hi julianorc,

no worries. The trick is that when I or techs test it, we do not experience this issue. This makes it very difficult to identify the case and find a solution.

The fact that not logged-in users will see information with a delay, it always will be. The trick is that this time difference is too long (based on comments on community). To show the problem to techs we need screenshots.

I am really sorry for not being able to share some useful info to you at the moment. However, anything submitted - all is shared with techs.

Maria
VS-Maria no está en línea   Reply With Quote
Old March 15th, 2019, 02:15 PM   #1275
julianorc
Juliano Costa, MSc.
 
Join Date: Aug 2013
Location: Uberaba/MG
Posts: 1,032
Likes (Received): 634

Quote:
Originally Posted by VS-Maria View Post
Hi julianorc,

no worries. The trick is that when I or techs test it, we do not experience this issue. This makes it very difficult to identify the case and find a solution.

The fact that not logged-in users will see information with a delay, it always will be. The trick is that this time difference is too long (based on comments on community). To show the problem to techs we need screenshots.

I am really sorry for not being able to share some useful info to you at the moment. However, anything submitted - all is shared with techs.

Maria

Ok, but how to post the preview for the entire page? I can make a printscreen only in the last post for each case. Not sure if it helps.
julianorc no está en línea   Reply With Quote
Old March 15th, 2019, 02:22 PM   #1276
julianorc
Juliano Costa, MSc.
 
Join Date: Aug 2013
Location: Uberaba/MG
Posts: 1,032
Likes (Received): 634

Quote:
Originally Posted by julianorc View Post
Ok, but how to post the preview for the entire page? I can make a printscreen only in the last post for each case. Not sure if it helps.

Firefox Logged in
julianorc no está en línea   Reply With Quote
Old March 15th, 2019, 02:24 PM   #1277
julianorc
Juliano Costa, MSc.
 
Join Date: Aug 2013
Location: Uberaba/MG
Posts: 1,032
Likes (Received): 634

Quote:
Originally Posted by julianorc View Post
Ok, but how to post the preview for the entire page? I can make a printscreen only in the last post for each case. Not sure if it helps.

Edge Anonymous User
julianorc no está en línea   Reply With Quote
Old March 15th, 2019, 02:25 PM   #1278
julianorc
Juliano Costa, MSc.
 
Join Date: Aug 2013
Location: Uberaba/MG
Posts: 1,032
Likes (Received): 634

Quote:
Originally Posted by julianorc View Post
Ok, but how to post the preview for the entire page? I can make a printscreen only in the last post for each case. Not sure if it helps.

Chrome Anonymous User


julianorc no está en línea   Reply With Quote
Old March 15th, 2019, 02:30 PM   #1279
vsadmin
Administrator
 
vsadmin's Avatar
 
Join Date: Feb 2018
Posts: 744
Likes (Received): 519

Got it! Thank you a lot, I will forward it to techs.

Maria
vsadmin no está en línea   Reply With Quote
Old March 15th, 2019, 09:23 PM   #1280
SMCYB
Registered User
 
SMCYB's Avatar
 
Join Date: Sep 2013
Posts: 1,481
Likes (Received): 2294

Anybody else getting an annoying pop-up video ad in the bottom corner lately?
SMCYB no está en línea   Reply With Quote
Sponsored Links
Advertisement
 


Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT +2. The time now is 01:02 PM. • styleid: 14


Powered by vBulletin® Version 3.8.11 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

SkyscraperCity ☆ In Urbanity We trust ☆ about us